[Fixed] Mysterious crash

View previous topic View next topic Go down

[Fixed] Mysterious crash

Post by Vanquisher_Bibe on Sun Jan 08, 2017 5:25 pm

---------------------------
Oops!
---------------------------
The game crashed.
The crash report folder named "2017-01-08_151042" next to game executable.
It would be great if you'd send it to the developer of the game!
---------------------------
OK  
---------------------------


So i just removed the control systems i was testing out for my x-wing test when all of a sudden i couldn't place any blocks at all, anywhere. So i hit F1 to save and made sure i could see the save indicator in the top left. Exited to title and attempted to reload my save. Save loaded with nothing at all in the scene. Exited again to load another save i had, same thing. Then i went to go back into my x-wing save and it crashed to the desktop. I rar'd the crash report folder it generated and attached it to the post. i can also cut that out of a video i was recording if you need to visually see what happened.

filedropper.com/2017-01-08151042

Vanquisher_Bibe

Posts : 15
Join date : 2017-01-06

View user profile

Back to top Go down

Re: [Fixed] Mysterious crash

Post by tsunamayo on Sun Jan 08, 2017 5:55 pm

Ok sorry for the crash I will investigate this asap. As a good practice if you attempt large build it is good to do a backup of your work after a good session so you dont loose it. In the future I will add some safeguard to minimize this risk.
Ok on the bug if you have the video it will be great to know what triggerer it! You were working on a system or something ? Anyway also can you send me your save folder ? You can place all the file in the dropbox, I made a folder at your name so you dont have to upload it somewhere.
The save is located in C:\Users\[USERNAME]\AppData\LocalLow\TsunamayoCorp\Skywanderers (the full folder is better)
Also if your player save is corrupted, you might still be able to load your ship : just create a new ship, put an identity block on it, and load an existing blueprint while giving it a new name.
Thanks for reporting the crash !

tsunamayo
Admin

Posts : 173
Join date : 2016-12-16

View user profile http://skywanderers.forumjap.com

Back to top Go down

Re: [Fixed] Mysterious crash

Post by Vanquisher_Bibe on Sun Jan 08, 2017 8:31 pm

no problems. it's part of a 3hr recording so i'll cut it up later on tonight and put it in dropbox for you.

Vanquisher_Bibe

Posts : 15
Join date : 2017-01-06

View user profile

Back to top Go down

Re: [Fixed] Mysterious crash

Post by Vanquisher_Bibe on Sun Jan 08, 2017 10:56 pm

It should be in dropbox now. I also uploaded a small video of an issue that just happened. used a small rotating block, put a second one on top and accidentally deleted the base before the rotating plate. now i can't delete or activate anything. i also can't save blueprints as i go. i either have to create a new blueprint each time i want to save my ship or if i click on the blueprint in the list it just reloads the old one.

Vanquisher_Bibe

Posts : 15
Join date : 2017-01-06

View user profile

Back to top Go down

Re: [Fixed] Mysterious crash

Post by tsunamayo on Mon Jan 09, 2017 9:17 am

Ok, just to confirm this is a second issue right ? I will try to reproduce this two, I keep you posted as soon as I have something new.

tsunamayo
Admin

Posts : 173
Join date : 2016-12-16

View user profile http://skywanderers.forumjap.com

Back to top Go down

Re: [Fixed] Mysterious crash

Post by Vanquisher_Bibe on Mon Jan 09, 2017 3:01 pm

Yeah its a second issue but its very similar to what happened before the game crashed with the original issue

Vanquisher_Bibe

Posts : 15
Join date : 2017-01-06

View user profile

Back to top Go down

Re: [Fixed] Mysterious crash

Post by tsunamayo on Mon Jan 09, 2017 3:34 pm

Ok I guess I reproduced then, I have an issue when putting a turret brick on a children entity.
I will fix that for the next update. Also I will most likely scrap the current turret logic to do something better (hopefully)

tsunamayo
Admin

Posts : 173
Join date : 2016-12-16

View user profile http://skywanderers.forumjap.com

Back to top Go down

Re: [Fixed] Mysterious crash

Post by Vanquisher_Bibe on Mon Jan 09, 2017 3:57 pm

awesome.

Vanquisher_Bibe

Posts : 15
Join date : 2017-01-06

View user profile

Back to top Go down

Re: [Fixed] Mysterious crash

Post by tsunamayo on Mon Jan 09, 2017 6:43 pm

Ok so I have fixed the issue with turret on children entity, still not sure 100 % it was your first issue, but it was clearly the second one. I will release a build soon.

tsunamayo
Admin

Posts : 173
Join date : 2016-12-16

View user profile http://skywanderers.forumjap.com

Back to top Go down

Re: [Fixed] Mysterious crash

Post by Sponsored content


Sponsored content


Back to top Go down

View previous topic View next topic Back to top

- Similar topics

 
Permissions in this forum:
You cannot reply to topics in this forum