[Fixed][Medium Priority][Game Performance] Huge lag spikes when moving ship while firing beam blocks laser

Go down

[Fixed][Medium Priority][Game Performance] Huge lag spikes when moving ship while firing beam blocks laser

Post by johnreverse on Thu Jan 12, 2017 1:10 am

Description of the issue: Huge lag spikes when moving ship while firing beam blocks laser
Frequency of the issue: Always
Steps to replicate the issue:
1. Fire the beam blocks laser(use the built-in one that comes with Saint Just)
2. Move your ship(you should get a huge lag spikes while moving)
Possible Workaround: Don't move the ship while firing
Additional Notes: When firing the laser at the gas giant it gets destroyed by a glitchy explosion(compared to the planet one) and then it leaves this aura


johnreverse

Posts : 49
Join date : 2017-01-08

View user profile

Back to top Go down

Re: [Fixed][Medium Priority][Game Performance] Huge lag spikes when moving ship while firing beam blocks laser

Post by tsunamayo on Thu Jan 12, 2017 8:38 am

haha ok I am gonna have a look at it I need to improve the merging beam logic. Also the planet destruction I will remove it (for now), as it was just a stupid things I did for fun for Rogue One :


tsunamayo
Admin

Posts : 173
Join date : 2016-12-16

View user profile http://skywanderers.forumjap.com

Back to top Go down

Re: [Fixed][Medium Priority][Game Performance] Huge lag spikes when moving ship while firing beam blocks laser

Post by johnreverse on Thu Jan 12, 2017 5:23 pm

Yeah I know it was just a fun gimmick Smile

johnreverse

Posts : 49
Join date : 2017-01-08

View user profile

Back to top Go down

Re: [Fixed][Medium Priority][Game Performance] Huge lag spikes when moving ship while firing beam blocks laser

Post by tsunamayo on Thu Jan 12, 2017 5:35 pm

Actually I just fixed the bug, I am making beam more robust there is a few other thing I want fix with them.

tsunamayo
Admin

Posts : 173
Join date : 2016-12-16

View user profile http://skywanderers.forumjap.com

Back to top Go down

Re: [Fixed][Medium Priority][Game Performance] Huge lag spikes when moving ship while firing beam blocks laser

Post by Sponsored content


Sponsored content


Back to top Go down

Back to top

- Similar topics

 
Permissions in this forum:
You cannot reply to topics in this forum